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CLASS-1
Chapter 1 – Machines and Computer

A.	 Choose the correct answer. 
	 1. a 	 2. b 	 3. b 	 4. a 	 5. b  
B. 	 Fill in the blanks. 
	 1. Automatic	 2. Tab	 3. Smartphone	 4. Battery-powered		 5. Refrigerator
C. 	 Match the following machines with their uses.  
	 1. d 	 2. a 	 3. b 	  4. c   
D. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. False (x)		  2. True ()	 3. True ()	 4. False (x)
E. 	 Answer the following questions. 
1. 	 The thing which is created by nature is called natural thing.  Two examples are- animals, plants. 

(Any other examples are also correct)
2.	 The thing which is created by human being is called man-made thing.  Two examples are – computer, 

Table. (Any other examples are also correct)
3.	 Machine is a man-made thing. It helps us to do work more easily and quickly. Two examples are – 

bus, television. (Any other examples are also correct)
4. 	 Two manual machines are – Bicycle, Stapler (Any other examples are also correct)
	 Two automatic machines are – Microwave, Television (Any other examples are also correct)
5. 	 Computer is a man-made thing. It can think and remember. It helps us do many tasks such as drawing, 

play games, etc. List of different type of computers are Desktop, Laptop, Tablet, Smartphone. 

Chapter 2 – What Computers are Made of?
A. 	 Choose the correct answer. 
	 1. b 	 2. a 	 3. b 	 4. c 	 5. a 
B. 	 Fill in the blanks. 
	 1. Clicking		  2. Joystick	 3. System unit		 4. Printer         5. Speakers, Headphone 
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C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. True ()	 3. True ()	 4. True ()	 5. False (x)
D. 	 Match the following parts of computer with their uses: 
	 1. d 	 2.  c 	 3.  e 	  4.  a	 5. b	  
E. 	 Answer the following questions.
1. 	 CPU controls all other parts and help the computer think and work. 
2. 	 i.  Monitor shows everything the computer is doing.
	 ii. It helps us to watch movies and play games on it. 
3. 	 Keyboard is used to type words, numbers and symbols on the computer. 
4. 	 A printer helps us to print the work done by the computer on paper.
5. 	 i.  	 Speakers helps us to listen music or sound played on the computer.
	 ii. 	 Joystick used to control the pointer on the monitor while playing game on the computer. 

Chapter 3 – Using a Computer
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. b 	 4. c 	 5. b 
B. 	 Fill in the blanks. 
	 1. Power switch	 2. Middle 	 3. Distance 	 4. UPS        	 5. Mouse pad
C. 	 Match the following: 
	 1. d	 2. e 	 3. a 	  4. b	 5. c  
D. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True () 		 2. False (x)	 3. False (x)	 4. True ()	 5. False (x)
E. 	 Answer the following Questions. 
1. 	 When the computer does not switch on due to any reason, we should contact our elders/teachers.
2. 	 UPS prevents computer from shutdown and keeps the computer safe. 
3. 	 i. keep your feet, neck and shoulders relaxed.	 ii. Hold mouse gently and correctly. 	
4. 	 Use clean, soft, and dry cloth to clean the computer. 
5. 	 Click on the start button > Use scroll bar to scroll down > Look for the required program > Click on 

it to open.

Chapter 4 – Click and Do with Mouse
A. 	 Choose the correct answer. 
	 1. a 	 2. a 	 3. c 	 4. d 	 5. b 
B. 	 Fill in the blanks. 
	 1. Wireless		  2. Click, Two		  3. Left		  4. Dragging        	 5. Scroll wheel
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. False (x)		  2. True ()	 3. False (x)	 4. True ()	 5. True ()
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D. 	 Match the following: 
	 1. b 	 2.  a 	 3. d   	  4. c   
E. 	 Answer the following questions. 
1. 	 Mouse pad is used to protect the mouse from dust and damage.
2. 	 Left button, right button, scroll wheel and cable
3. 	 Pressing the left mouse button one time is called single-click and pressing the left mouse button 

two times is called double-click.  
4. 	 Scroll wheel is used to move up and down on the screen.
5.	 Index finger, middle finger 

Chapter 5 – Tab, Tap! Keyboard Zap!
A. 	 Choose the correct answer. 
	 1. b 	 2. b 	 3. b 	 4. c 	 5. c 
B. 	 Fill in the blanks. 
	 1. Keys	 2. Alphabet 	 3. Enter	 4. Spacebar		  5. Backspace
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x) 	 3. True () 	 4. False (x)	 5. True ()
D. 	 Match the following: 
	 1. c 	 2.  d 	 3. e   	  4. a	 5. b	   
E. 	 Answer the following questions. 
1. 	 Caps lock key is used to type text in capital letters.
2. 	 There are 26 alphabet keys on the keyboard.
3. 	 Number keys can be found in two places: i. above the top row of the alphabet keys. ii. right side of 

the numeric keypad.
4. 	 Backspace key erases letters or number to the left of the cursor.
5. 	 Delete key is used to erase letters or numbers on the right side of the cursor whereas backspace 

key erases number or letters left of the cursor.  

Chapter 6 – Tux Paint Fun 
A. 	 Choose the correct answer. 
	 1. b 	 2. b 	 3. b 	 4. a 	 5. b 
B. 	 Fill in the blanks. 
	 1. color palette	 2. Drawing canvas	 3. Stamps 	 4. Shapes         	 5. Quit
C. 	 Answer the following questions.
1. 	 Toolbar, Canvas, Selectors, Colors palette
2. 	 Shape tool is used to draw red circle and Fill tool is used to fill colour in it. 
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3. 	 Erase tool is used to remove parts of the drawing. 
4. 	 i. 	 Line: This tool is used to draw straight lines.
	 ii. 	 Fill: This tool is used to fill colours in any closed shape. 
5. 	 Colors palette helps to choose and fill colours in your drawing. 

Chapter 7 – Little Coders’ Paradise: ScratchJr.
A. 	 Choose the correct answer. 
	 1. b	 2. d	 3. b	 4. a	 5. c
B. 	 Fill in the blanks. 
	 1. Sprite	 2. Start in Green Flag	 3. Move right		  4. Stage	 5. Backdrop
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. False (x)		  2. True ()	 3. False (x)	 4. True ()	 5. False (x)
D. 	 Answer the following questions.
1. 	 ScratchJr. Allows to learn basics of coding and develop the logical skills.
2. 	 We can attach various block to create a sequence of actions in ScratchJr.
3.	 Trigger: Respond to taps, starting flags, or sending/receiving messages.
	 Looks: Change characters’ appearance, make them hide or show, or change scenes, such as making 

a character change colours like a chameleon.
	 Motion: Move characters left, right, up, down, or in a specific direction, like making a car  

drive forward. 

CLASS 2
Chapter 1 – Computers Everywhere!

A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. b 	 4. c 	 5. c  
B. 	 Fill in the blanks. 
	 1. Internet		  2. Lessons	 3. Email	 4. Medical	 5. Bills
C. 	 Match the following machines with their uses.  
	 1. c 	 2. a 	 3. e 	  4. b	 5. d   
D. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. True ()	 4. False (x)	 5. False (x)
E. 	 Answer the following questions. 
1. 	 i. play games		  ii. Complete school projects.
2. 	 Computer helps teacher to prepare question papers and result. 
3. 	 Computer used in hospitals for treatment and diagnosis. 
4. 	 Computer used to prepare bills and track items in the store. 
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Chapter 2 – A Computers System
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. b 	 4. c 	 5. b  
B. 	 Fill in the blanks. 
	 1. Input		  2. Hard copy		  3. Processing		  4. Headphone		 5. Microphone
C. 	 Match the following machines with their uses.  
	 1. b 	 2. d 	 3. a 	  4. c	 5. e   
D. 	 Answer the following questions. 
1. 	 Input devices are used to give instructions to the computer. Example: Keyboard, mouse
2. 	 Output devices show the result of all the work done on the computer. Example: Monitor, printer
3. 	 The CPU processes the data and information given by the input devices to the computer.
4. 	 The storage device used to store and keep our work, data and information safe for future use. 

Example: hard disk drive, pen drive
5. 	 Input devices are used to give instructions to the computer whereas output devices show the 

result of all the work done on the computer.

Chapter 3 – Peeping Down the Windows
A. 	 Choose the correct answer. 
	 1. c 	 2. a 	 3. c 	 4. b 	 5. c  
B. 	 Fill in the blanks. 
	 1. Start	 2. Alphabetical 	 3. System tray	 4. Window key+ D 	 5. Task view
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. True ()	 4. True ()	 5. True ()
D. 	 Match the following.  
	 1. b	 2. d 	 3. a 	  4. c	
E. 	 Answer the following questions. 
1. 	 The strip from the left to right at the bottom of the desktop is called taskbar. 
2. 	 Desktop is the first screen we see when the computer is turned on. 
3. 	 Icon shows a program, file or file or folder on the computer. 
4. 	 Start button displays options to open various program on the computer. 
5. 	 The picture over the desktop is called wallpaper.  

Chapter 4 – Tux Paint: Advanced 
A.	 Choose the correct answer. 
	 1. b 	 2. b 	 3. c 	 4. b 	 5. b  
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B. 	 Match the following.  
	 1. d	 2. a 	 3. c 	  4. b
C. 	 Fill in the blanks. 
	 1. Stamp	 2. Size 	 3. Line	 4. Text, Label 		  5. Slideshow
D. 	 Answer the following questions. 
1. 	 Stamp tool is used to add pre-drawn or images in the drawing.  
2.	 i. 	 Fill tool: It fills a closed area with colour.
	 ii. 	 Flower tool: It draws pretty flowers of different shapes and colours. (Any other tool is  

also correct) 
3. 	 Freehand drawing means you can draw anything you want just like using a real paintbrush.  
4. 	 Slideshow is used to run all the slides or diagram one after another.

Chapter 5 – Introduction to MS Paint 
A. 	 Choose the correct answer. 
	 1. a 	 2. b 	 3. b 	 4. b 	 5. b  
B. 	 Fill in the blanks. 
	 1. Ribbon	 2. Edit color	 3. Color 1	 4. 2 	 5. Erase
C. 	 Match the following tools with their functions.  
	 1. c	 2. d 	 3. b 	  4. e	 5. a
D.	  Tick () the correct statement and cross (x) out the wrong one. 
	 1. False (x)		  2. False (x)	 3. True ()	 4. True ()	 5. True ()
E. 	 Answer the following questions. 
1. 	 color palette is used to select various colours to fill in the drawing. 
2. 	 Foreground color is used for pencil, fill color, text and outline of the drawing. 
3. 	 Tab, Title bar and Ribbon (any other parts are also correct)
4.  	 We use erase tool to remove unwanted parts and mistakes of the drawing. 
5. 	 Line tool is used to draw straight lines of different thickness and colours as per our drawing. 

Chapter 6 – More Fun with ScratchJr. 
A.	  Choose the correct answer. 
	 1. c 	 2. a 	 3. b 	 4. b 
B. 	 Fill in the blanks. 
	 1. Young children	 2. Movement		  3. Computational thinking		  4. Loops
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. False (x)		  2. True ()	 3. False (x)	 4. True ()
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D. 	 Answer the following questions. 
1. 	 ScratchJr. is designed for young children to create interactive stories and games. 
2. 	 Sound block is used to add sound effect in ScratchJr. 
3. 	 Motion blocks are used to control character movements in ScratchJr.  
4. 	 Loop block is used to repeat a set of instructions multiple times.  

Chapter 7 – WordPad: My First Word processor
A. 	 Choose the correct answer. 
	 1. d 	 2. a 	 3. c 	 4. c	 5. c 
B. 	 Fill in the blanks. 
	 1. Ribbon	 2. Work area 	 3. File name		  4. Double	 5. Superscript
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. True ()	 3. False (x)	 4. False (x)	 5. True ()
D. 	 Match the following tools with their functions.  
	 1. c	 2. d 	 3. b 	 4. a
E. 	 Answer the following questions. 
1. 	 Title bar, Ribbon, Work area, Control buttons, Zoom control, Tab
2. 	 Changing the appearance of character, alignment and size of text is called formatting.  
3. 	 i. Bold: It makes the selected the text bold.		  ii. Italic: It makes the selected text italics.
	 iii. Underline: It underline the selected text. 
4. 	 Control buttons are used to maximize, minimize, restore and close the WordPad window.

CLASS 3
Chapter 1 – Working of a Computer

A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. b 	 4. c 	 5. d  
B. 	 Fill in the blanks. 
	 1. Process		  2. ALU		 3. CPU box		  4. System	 5. Software
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. False (x)	 4. True ()	 5. False (x)
D. 	 Answer the following questions. 
1. 	 Memory unit keeps all the data and information that the computer needs to use. 
2. 	 I-P-O is the input, process and output cycle to complete any task.
3. 	 We can touch and see the hardware whereas software cannot be touched. 
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4. 	 Arithmetic and Logic unit (ALU), Control Unit (CU) and memory Unit (MU)
5. 	 CPU helps to think and work by following the instruction given to it, perform mathematical 

calculation and control different parts of the computer. 
E. 	 Match the following tools with their functions.  
	 1. b	 2. a 	 3. d 	 4. C

Chapter 2 – GUI Operating System
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. a 	 4. c 	 5. c  
B. 	 Fill in the blanks. 
	 1. DOS	 2. Booting	 3. Chrome OS	 4. Interface	 5. Operating system
C. 	 Answer the following questions. 
1. 	 Operating system is a software that controls all parts of a computer. 
2. 	 i. Work area			  ii. Status bar (any other part is also correct)
3.	 The way we interact and communicate with a computer is called interface. 
4. 	 Right click on the desktop > click the view option from the pop-up menu > click on the show 

desktop icon to hide.
D. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. True ()	 3. False (x)	 4. False (x)	 5. True ()
E. 	 Match the following tools with their functions.  
	 1. d	 2. b 	 3. a 	  4. c

Chapter 3 – Working with Data
A. 	 Choose the correct answer. 
	 1. a	 2. c 	 3. a 	 4. a 	 5. a  
B. 	 Fill in the blanks. 
	 1. Folder	 2. Image	 3. File	 4. Desktop	 5. Right-click
C. 	 Answer the following questions. 
1. 	 A computer file stores our work. A folder stores files and other folders on the computer.
2. 	 A drive is a big storage space on the computer, where we keep files and folders. 
3.	 This PC shows the files, folders and drives on the computer.   
4. 	 This PC window has two parts: i. Folders and Drives ii. Content
D. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. False (x)	 4. False (x)	 5. True ()
E. 	 Match the following tools with their functions.  
	 1. d	 2. a 	 3. b 	 4. C
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Chapter 4 – MS Paint: Advanced
A. 	 Choose the correct answer. 
	 1. b	 2. b 	 3. b 	 4. d 	 5. d  
B. 	 Fill in the blanks. 
	 1. Rectangular		  2. Flip		  3. Ctrl + N	 4. Drag	 5. Wallpaper
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. True ()	 4. False (x)	 5. True () 
D. 	 Answer the following questions. 
1. 	 Rectangular tool is used to select a rectangular region of an image and free-form tool select 

irregular area of the drawing. 
2. 	 On the Home tab in the Image group > Click on the arrow on Select > Select the Select all selection 

option from the list. 
3.  	 Select the part to be removed > Bring the mouse cursor inside the selection, cursor converts into 

four-sided arrow > Drag the selected part to the new location.
4.	 Click on the File menu > Click on the New option > A new blank drawing appears in paint window.
5. 	 A. 	 Color picker tool picks a colour from one part of the drawing and fill the same colour in other 

part of the drawing. 
	 B. 	 Magnifier tool is used to zoom in and out the part of drawing. 
	 C. 	 Flip tool is used to rotate the drawing.
	 D. 	 Select all tool is used to select the entire drawing. 
E. 	 Match the following tools with their functions.  
	 1. b	 2. e 	 3. d 	  4. a	 5. c 

Chapter 5 – Problem Solving with RoboMind
A. 	 Choose the correct answer. 
	 1. d	 2. a 	 3. b 	 4. a 	 5. a  
B. 	 Fill in the blanks. 
	 1. 4		  2. Programmer		  3. Instruction pane		  4. Tile		  5. Ctrl + M
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. True ()	 3. False (x)	 4. True ()	 5. False (x)  
D. 	 Match the following tools with their functions.  
	 1. c	 2. d 	 3. a 	  4. b

 Chapter 6 – Visual Coding with Scratch
A. 	 Choose the correct answer. 
	 1. c	 2. d 	 3. a 	 4. a 	 5. c  
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B. 	 Fill in the blanks. 
	 1. Control		  2. Blocks	 3. Stage	 4. Sprite	 5. Script
C. 	 Answer the following questions.
1. 	 Menu bar, Coding area, Sprite, Stage area
2. 	 Code blocks help to create and control a program in scratch.
3. 	 The Wait block helps the program to pause for a specified amount of time before executing the 

next block of code. 
4. 	 i. When Flag clicked 			   ii. Mouse click
D. 	 In one line, write the use of the following blocks. 
1. 	 This block indicates that the project will begin when the sprite(s) on the stage is clicked.
2. 	 This block specifies a duration for how long it will take the sprite to move to the stated point.
3. 	 This block allows you to display text on the stage associated with a specific sprite.
4. 	 The Instrument block helps the user in adding the sounds of different instruments to their projects.

Chapter 7   – Introduction to Word Processing
A. 	 Choose the correct answer. 
	 1. b	 2. c 	 3. a 	 4. c 	 5. b  
B. 	 Fill in the blanks. 
	 1. Page margin	 2. Ribbon	 3. Enter	 4. Working	 5. File
C. 	 Tick () the correct statement and cross (x) out the wrong one. 
	 1. True ()		  2. False (x)	 3. True ()	 4. True ()	 5. False (x)
D. 	 Match the following tools with their functions.  
	 1. c	 2. e 	 3. a 	  4. d	 5. b	
E. 	 Answer the following questions.
1. 	 A word processor is a program that create, change, save and print text document. It is used to: 
	 i. Type, edit and format text 			   ii. Insert images and shapes 
2. 	 Go to File > New > Blank Document 
3. 	 Text can be selected with the help of keyboard by pressing arrow keys and Shift key together. 
4. 	 File > Save option > Click on Browse button > Type the file name > Click on save button
5. 	 Moving the text or pages up and down of the document on a screen is called scrolling. 

Chapter 8   – TupiTube-My First Animation
A. 	 Choose the correct answer. 
	 1. c	 2. d 	 3. d 	 4. a 	 5. b  
B. 	 Fill in the blanks. 
	 1. Stage		  2. Animation		  3. .tup, MP4		  4. Frames	 5. Play
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C. 	 Label the following image.
	 Side panel, Tabs, Standard toolbar, Exposure Sheet, Shape, Stage, Properties panel, Toolbar, Stage 

Toolbar (Refer textbook page no. 74)
D. 	 Answer the following questions.
1.	 i.	 Animation: A set of several drawing arranged in a sequence.
	 ii.	 Frame: Each drawing in the animation is called a frame.
	 iii.	 Tweening: It automatically generates further frames for the animation.
	 iv.	 Library: A collection of assets such as images, sound, etc.
	 v. 	 MP4: A video file format.
2.	 Motion tween, Colouring tween, Scale tween, Rotation tween 
3.	 To slow down the animation speed in TupiTube while previewing, we have to adjust the frame per 

second setting. Lowering the FPS reduces the number of frames shown per second, making the 
animation slower. 

CLASS 4
Chapter 1 – MS Word: Recap & Editing and Formatting

A. 	 Choose the correct answer. 
	 1. b 	 2. d 	 3. b 	 4. d 	 5. c	 6. b	 7. c  
B. 	 Fill in the blanks. 
	 1. Subscript		 2. Justify	 3. Bullet	 4. Font		 5. Highlight		  6. Align
C. 	 State “T” for True and “F” for False.
	 1. T	 2. F	 3. T	 4. F	 5. T	 6. T
D. 	 Answer the following questions. 
1. 	 First select the text you want to change the font size.  Then, go to the Home tab and choose the Font 

size from the Font size list. You can also type the font size in the box and press Enter key. 
2. 	 Bullet lists are used when the order doesn’t matter or non-sequential items, whereas numbered 

lists are used for showing steps or a sequential item.  
3. 	 Go to the Home tab > Find the Font group > Click on the Text Highlight Color drop-down and pick 

your favourite color. 
4. 	 Go to the Home tab in the Font group > Click on the Change Case drop-down and choose the 

required case. 
5. 	 Text alignment shows how the text is spread in the working area of the MS Word. There are different 

type of text alignment available in MS Word : Left aligned, Right aligned, Center aligned and Justify.

Chapter 2 – Introduction to Microsoft PowerPoint
A. 	 Choose the correct answer. 
	 1. b 	 2. d 	 3. a 	 4. b 	 5. a	 6. b	 7. c  	 8. d
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B. 	 Fill in the blanks. 
	 1. Slide pane	 2. Bullet    	 3. Slide show   	 4. Duplicate slide   	
	 5. Blank presentation 	 6. shift+F5
C. 	 State “T” for True and “F” for False.
	 1. T	 2. F	 3. T	 4. T	 5. F
D. 	 Answer the following questions. 
1. 	 Presentation is a collection of information, pictures and text arranged to make it easy to understand 

the topic. Examples – OpenOffice, Impress
2. 	 Quick Access Toolbar, Title bar, Ribbons, Slide pane
3. 	 Go to the desired slide > Insert tab > In the Text group > Text Box button
4.	  i.	 Gradient Fill: A gradient is a mix of multiple colours.
	 ii.	 Picture or Texture Fill: Texture is a surface like appearance of colourful designs.
	 iii.	 Pattern Fill: Pattern is a repeated decorative design.  
5. 	 Text can be positioned following ways in PowerPoint:
	 i.	 Left aligned: Text aligned to left margin of the text box.
	 ii.	 Right aligned: Text aligned to right margin of the text box.
	 iii.	 Center aligned: Text aligned to center of the text box.
	 iv.	 Justified aligned: Text spread equally between left and right margins. 

Chapter 3 – Windows Customization
A. 	 Choose the correct answer. 
	 1. d 	 2. b 	 3. d 	 4. a 	 5. c  
B. 	 Fill in the blanks. 
	 1. GUI	 2. 1    	 3. Theme   	 4. Transparency   	 5. Screen saver 

Chapter 4 – Managing Data
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. a 	 4. c 	 5. a	 6. c
B. 	 Fill in the blanks. 
	 1. Recycle Bin		  2. Clipboard    	 3. Context menu   		  4. Sub-folder   	
	 5. Ctrl			   6. Moving
C. 	 State “T” for True and “F” for False.
	 1. F	 2. T	 3. F	 4. T	 5. T
D. 	 Answer the following questions. 
1. 	 A folder stores files and other folders. A folder inside another folder is called sub-folder. 
2. 	 This PC window allows to access all the files and folders on the computer.  
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3. 	 i.	 Open the This PC window, open the location where you want to create a new folder.
	 ii.	 Click on the New Folder button on the toolbar. 
	 iii.	 A new folder is created. Type a name for the folder and press Enter key.
4. 	 Right click on the required file/folder > Context menu appears > Select the Delete option. 
5. 	 Go to the Desktop and double – click on the Recycle Bin icon. It shows all the deleted files and 

folders > Selected the files and folders to restore  > Click on the Restore the selected items buttons 
under Manage tab. 

Chapter 5 – The Internet Network of Networks
A. 	 Choose the correct answer. 
	 1. b 	 2. c 	 3. b 	 4. d 	 5. a
B. 	 Fill in the blanks. 
	 1. Telephone line	 2. E-commerce    	 3. Hyperlink   		 4. Chat   	 5. Web address
C.	 Answer the following questions. 
1. 	 Uniform Resource Locator (URL): It is another name for web address of a website or address to 

any resource on the internet such as music, movie, etc.  
	 Website: The prime online location on the internet is identified by unique web addresses or URLs.
	 Web page: All the information on website is distributed in several web pages which are connected 

with each other thorough hyperlinks.
	 Home Page: The first web page that is displayed when we visit a website is called home page. 
	 Hyperlink: Any part of a web page which is clicked to jump to the linked resource is called  

a hyperlink.
	 Search engine: Search on the internet is provided by specialized website called search engine.
2. 	 The internet is the network of computers spread all over the world including smartphones and 

other digital devices. Uses of internet are: 	 i. Information search    	 ii. Communication   	  
iii. Buying and selling

3. 	 Search on the internet is provided by specialized website called search engine. Example: Google, 
MS Bing, Ask.com

4. 	 A browser is a software application that allows users to access and interact with content on  
the World Wide Web. Example: Google Chrome, Mozilla Firefox, Apple Safari, Microsoft Edge, 
and Opera

D.	 Match the following example with their correct application.
	 1. c		  2. d	 3. e		  4. a		  5. b 

Chapter 6 – Logical Skills with RoboMind
A. 	 Choose the correct answer. 
	 1. c 	 2. a 	 3. d 	 4. a 	 5. d
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B. 	 Fill in the blanks. 

	 1. frontIsClear	 2.  frontIsbeacon    	 3. False	 4. True	 5. Logical

C.	 Answer the following questions. 

1. 	 Click on File > Open Map > In Open dialog box, select the file findSpot1.map and click Open button.

2. 	 Go to File > Open Map and open the file passBeacons1.map, then write the program and click on 
Run it.

3. 	 Repeat used to move or turn Robo multiple times in a sequence by taking a number within 
parentheses and instructions inside the block and execute as many times as the number.

4. 	 if-else block help in decision making. If block takes the command and execute only if the checked 
condition is true otherwise else block will execute.

Chapter 7 – Programming Concepts with Scratch
A. 	 Choose the correct answer.
	 1. a 	 2. a 	 3. b 	 4. d 	 5. c
B. 	 Fill in the blanks.

	 1. Action, Program 	 2. Condition 	 3. Costumes 	 4. Forever 	 5. Categories

C. 	 Mark the following statements as True or False.

	 1. False 	 2. True 	 3. False 	 4. True 	 5. False

D. 	 Answer the following questions.

1.	 i.	 If-then block contains a slot for putting a condition to check. When the condition gets fulfilled 
(true) then blocks place in the if block are executed.

	 ii.	 This event block is used to run the attached blocks when start button (Green flag) is clicked.

	 iii.	 This block changes the costume of the sprite to the selected costume (e.g., cake-b).

	 iv.	 This is the Start or Go button to run a program. Clicking on this generates “When flag  
clicked” event.

	 v.	 This is a loop block that infinitely executes the blocks placed inside it.

2. 	 An event occur due to the user’s action or program. The two event blocks in Scratch are “when 
green flag clicked” and “when this sprite clicked”.

3. 	 We call forever block a loop block because it infinitely executes the blocks placed inside it.

4. 	 To change the costume of the sprite, we use “switch costume to” block. It changes the costume of 
the sprite to the selected costume (e.g., cake-b).

5. 	 Sound panel is displayed by clicking on sounds tab next to costume tab. You can add new sounds, 
record sounds and edit sounds. 

6. 	 Tabs, Blocks, Script Pane, Stage, Stage Setting
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Chapter 8 – Animation Basics with TupiTube
A. 	 Choose the correct answer.
	 1. c 	 2. d 	 3. d 	 4. a 	 5. B
B. 	 Fill in the blanks.
	 1. Stage 	 2. Animation 	 3. .tup, MP4 		  4. Frames 	 5. Player
C. 	 Label the Following image.
	 Side Panel, Tabs Standard Toolbar, Exposure Sheet, Shape, Stage,
	 Toolbox, Properties Panel, Stage Toolbar
D.	 Answer the following questions.
1. 	 i. 	 A series of drawings passed at a very high speed before eyes give the illusion of animation.
	 ii. 	 Frame is one piece of drawing in entire animation.
	 iii. 	Tweening automatically generates further frames for animation.
	 iv. 	 A collection of objects such as images etc. useful for any animation project is called Library.
	 v. 	 MP4 is the latest multimedia video file format.
2. 	 Four tweening effects in TupiTube are Motion, Rotation, Scale, Coloring. (Other 2 are Shear and 

Opacity).
3. 	 To slow down the animation speed, we reduce the number of frames in the Preview.

Chapter 9 – Experience AI
A. 	 Choose the correct answer.
	 1. c 	 2. b 	 3. b 	 4. a 	 5. d
B. 	 Fill in the blanks.
	 1. Voice assistant	 2. Sensors 	 3. mathematical	 4. Problem-solving	
	 5. Training, Testing
C. 	 State “T” for True and “F” for False.
	 1. T	 2. T	 3. F	 4. T	 5. T
D. 	 Answer the following questions.
1. 	 The device use advanced technology to perform tasks is called smart device. Example: Smartphones, 

Smart TV, Smart Car, Smartwatches, Drones  
2. 	 Intelligence is the ability to understand, think, learn, and solve problems. Example:  Linguistic 

intelligence, Mathematical intelligence, Musical intelligence, Bodily-kinaesthetic intelligence
3. 	 When computers and machines are made to think   and learn like humans is called Artificial 

intelligence. Machine learning is the way to train the computers with data to do various tasks 
instead of programming them.

4. 	 Uses of AI are: 
	 i. 	 AI can learn from the text and speech.
	 ii. 	 AI models can create summary of large texts.
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	 iii. 	AI is used to analyses the already present data and predict the future value by correlating 
various data values.

	 iv.	 AI can be used to search for visually similar images or objects. 
5.	 a. 	 when I hear block lets sprites respond to specific sounds or voices. 
	 b. 	 set voice to block is used to change the voice in different tones or characters. 
	 c. 	 Set language to block allows sprites to speak in various languages, making projects accessible 

and engaging. 
	 d. 	 Listen and wait block makes the robot wait for the user to speak. Whenever user will speak it 

will be captures by microphone. 

CLASS 5
Chapter 1 – Ages of Computers

A. 	 Choose the correct answer. 
	 1. a 	 2. c 	 3.  d	 4.  b	 5. c	   
B. 	 Fill in the blanks. 
	 1. Abacus	 2. Tabulating Machine	 3. ENIAC	 4. IBM 360	 5. Cloud
C.  	 Answer the following questions. 
1. 	 Abacus, Napier’s Bones, Pascaline, Analytical Engine and Tabulating machine
2. 	 First Generation (1940s–1956): Technology: Vacuum Tubes; Second Generation (1956–1963): 

Technology: Transistors; Third Generation (1964–1971): Technology: Integrated Circuits (ICs); 
Fourth Generation (1971–Present): Technology: Microprocessors; Fifth Generation (Present and 
Beyond): Technology: Artificial Intelligence (AI) and Very Large-Scale Integration (VLSI)

3. 	 1st Gen: Machine Language, Assembly language; 2nd Gen: COBOL and FORTRAN; 3rd Gen: C and 
PASCAL; 4th Gen: C++,Java

4. 	 a.	 Differences Between Mainframes and Supercomputers: 1. Smaller in size than the 
supercomputer. 2. Cheaper than super computers. Super Computer are very costly.

	 b. 	 Differences Between Mini and Micro-computers: 1. Mini Computers are expensive and larger 
than microcomputers. 2. Mini computer are large but Micro computers are portable.

5. 	 The fifth generation focuses on AI ,Cloud computing , IOTs. Artificial intelligence (AI), powered by 
machine learning and deep learning, is transforming machines into intelligent systems capable 
of tasks like facial recognition, predictions, and autonomous operations. The future promises 
intelligent devices, advanced human-machine interaction, autonomous vehicles, and immersive 
virtual worlds. However, ethical concerns, job displacement, and control over intelligent technology 
remain critical issues for society to address.

Chapter 2 – Document Design in MS Word
A. 	 Choose the correct answer. 
	 1. b 	 2. b 	 3. b 	 4. d 	 5. a	  



19

B. 	 Fill in the blanks. 
	 1. 1		  2. Cover page    	 3. section, page   	 4. Symbol   	 5. Mouse
C. 	 Answer the following questions. 
1. 	 Open Layout tab >Page Setup group > Orientation drop-down and select the desired page orientation. 
2. 	 i. 	 Insert tab > Header & Footer group >Page Number drop-down. 	  
	 ii. 	 Select the desired location for the page number.      iii. Click on the style of  the page number.
3.	 i. 	 Layout tab > Page Setup group > Columns drop-down. 
	 ii. 	 Select the desired number of columns.			   iii. Click ok
4.  	 Headers and footers provide consistent information like page numbers, titles, and dates, improving 

document structure and appearance. It organizes content across multiple pages.
5. 	 In the Insert Tab>Symbol dialog box > go to Special Characters tab > Select the desired character 

> Click Insert.

Chapter 3 – Document Enhancement Tools
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. a 	 4. b 	 5. c 	 6. a 
B. 	 Fill in the blanks. 
	 1. Find	 2. Undo   	 3. Shading  	 4. Thesaurus   	 5. Borders	 6. Redo
C. 	 State “T” for True and “F” for False.
	 1. T	 2. F	 3. F	 4. T	 5. F
D. 	 Answer the following questions. 
1. 	 Copying: Creates a duplicate of the selected text and places it in another location, leaving the 

original text unchanged.
	 Moving: Transfers the selected text to a new location, removing it from its original position.
2. 	 It helps in searching for a word or text in the document and replace it with another word. It makes 

it easy to change words quickly in the whole document without doing it one by one.
3. 	 Line spacing: Adds space between the lines in a paragraph.
	 Paragraph spacing: Adds space before or after a paragraph.
4. 	 It is important because they help find and correct spelling and grammar mistakes in the document. 

This makes our writing look better and easier to understand.

Chapter 4 – MS PowerPoint: Slide Layout and Graphics
A. 	 Choose the correct answer. 
	 1. c 	 2. c 	 3. a 	 4. b 	 5. d	
B. 	 Fill in the blanks. 
	 1. Table	 2. Blank   	 3. Picture Slide, adjust   	 4. Icons   	 5. Section Header	
	 6. Bar Chart, Area Chart, Pie Chart
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C. 	 Answer the following questions. 
1. 	 It is a software which is used to create presentations. It allows us to design slides with text, images, 

charts, videos, and other multimedia elements.
2. 	 Click on Insert tab >  On Title and Content slide layout > click on Insert Pictures >  Locate and select 

the picture and click on Insert button.
3 	 Pictures make a slideshow more interesting and help explain ideas clearly. Charts show data in a 

simple way, making it easier to understand.
4. 	 Title Slide: This is usually the first slide you see in a presentation. It shows the title of your 

presentation and can also include a subtitle.
	 Picture with Caption: Use this layout to place a picture on the right side of the slide, with a title and 

description on the left side.
5. 	 SmartArt helps to create cool, organized graphics quickly. To add it, go to the Insert tab > click 

SmartArt > choose a design > and add your text. This makes the slide look neat and easy to 
understand.

Chapter 5 – Electronic Spreadsheet in MS Excel
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3. b 	 4. d 	 5. C	 6. a 	 7. d 		  8.b
B. 	 Fill in the blanks. 
	 1. Data set		  2. Arrow keys    	 3. B1:B3   	 4. Status Bar  		 5. Column
C. 	 Answer the following questions. 
1.	 An electronic spreadsheet is a software application that allows users to organize, store, and 

manipulate data in a tabular form using rows and columns. It provides tools for calculations, data 
analysis, and visual representation of data.

	 It stores data in a grid layout, where information is organized into rows (horizontal) and columns 
(vertical). Each cell in the grid can hold a value, formula, or text. 

2. 	 i. 	 In electronic spreadsheets, data is stored in a structured layout of columns and rows. This 
tabular structure helps in working with the data easily.

	 ii. 	 Spreadsheets provide a huge library of graphs and charts to present the data in graphical form.
	 iii. 	Electronic spreadsheets let us perform various calculations with the help of formulas and 

built-in functions.
	 iv. 	 Spreadsheets provide features of filtering, sorting and formatting the data according to the 

value – this is called conditional formatting, validating the data, grouping the data, calculating 
subtotals, creating summary of the data, etc.

3. 	 A cell range is a group of two or more cells in a spreadsheet that are selected or referenced together.
	 Examples of cell ranges:
	 A1:B3 — This range includes cells A1, A2, A3, B1, B2, and B3.
	 C5:C10 — This range includes cells from C5 to C10, vertically in a single column.
	 It is written by specifying the first cell and the last cell in the range, separated by a colon (:).
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4. 	 Cell in a spreadsheet is identified by a unique combination of a column letter and a row number. 
This allows us to refer to specific cells easily. 

	 Example: The cell at the intersection of column B and row 3 is referred to as B3. No other cell will 
have the same combination of column and row, so B3 is its unique location.

D. 	 Investigate the following statements and write down the facts you find.
1.	 Fact: An electronic spreadsheet can display data in various forms, including text, numbers, and 

formulas, depending on the type of data entered into the cells.
2.	 Fact: Charts visually represent data, helping users quickly analyse trends, patterns, and 

comparisons, making large datasets easier to understand.
3.	 Fact: Modern tools like Google Sheets or Excel’s Share and Collaborate feature allow easy sharing 

of spreadsheets with multiple users, enabling real-time collaboration.
4.	 Fact: Some basic formatting like font styles and colours can be done in MS Word or PowerPoint, 

but advanced Excel-specific formatting, like conditional formatting or formula-based adjustments, 
cannot.

5.	 Fact: A cell range refers to a group of cells (e.g., A1:B3), not necessarily all the data in the sheet. 
Selecting all data in a sheet is called selecting the entire worksheet.

Chapter 6 – MS Excel: Basic Worksheet operations
A. 	 Choose the correct answer. 
	 1. a 	 2. c 	 3. b 	 4. d 	 5. d 	 6. b
B. 	 Fill in the blanks. 
	 1. Select	 2. Automatically, Manually    3. Redo	 4. Custom list, Fill handle     5. Active
C. 	 Answer the following questions. 
1. 	 Manoj needs to perform the following steps:
	 i. 	 File tab > More > Options > In the Excel Options dialog box, Advanced section. 
	 ii. 	 In the right pane, scroll down to General section and click on Edit Custom Lists button. The 

Custom Lists dialog box appears.
	 iii. 	In the List entries box, type the new list (Names of Departments).
	 iv. 	 Click on Add button. The entered list appears in the Custom lists box.
2.	 Right Click > Click on Copy > Go to the desired cell > Right Click > Click on Paste
3.	 Changing the Column Width
	 Method 1 (using command on the Ribbon):
	 i. 	 Select the columns (using column header).
	 ii. 	 On Home tab, in Cells group, click on Format button. A drop-down menu appears.
	 iii. 	Click on AutoFit Column Width option to automatically adjust the column width.
		  Or, to manually adjust the column width, click on Column Width option. 
	 iv. 	 The Column Width dialog box appears.
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	 v. 	 Type the required width and click on OK button. See the changes in the width of the selected 
columns.

	 Method 2 (using mouse):
	 i. 	 Put mouse cursor on the border of the row (header), the cursor changes.
	 ii. 	 Now, click and drag the border of row header to increase or decrease the row height.
	 iii. 	After getting the desired height release the mouse button.
4. 	 A Custom List in Excel helps you quickly fill in repeated data, like Subject List, Department List etc.. 

For example, if you type “English” and drag the fill handle, Excel will automatically fill in the other 
days like Maths, Science, and so on.

5. 	 Steps to delete a cell/row/column are:
	 i. 	 Select the cell/row/column that you want to delete. (Click on row/column header to select it).
	 ii. 	 On Home tab, in Cells group, click on Delete button. A drop-down menu appears.
	 You can also delete a cell/row/column using right-click.
	 1. 	 Right-click on the cell, a drop-down menu appears.
	 2. 	 Click on Delete option. The Delete dialog box appears.
	 3. 	 Select the required option.

Chapter 7 – Internet search & Common services
A. 	 Choose the correct answer.
	 1. c 	 2. b 	 3. c 	 4. d 	 5. a
B. 	 Fill in the blanks.
	 1. Firefox, Edge 		 2. Back, forward 	 3. blue, Gray   		 4. E-Commerce
C. 	 Answer the following questions.
1. 	 To access the services on the internet, we use the software called a web browser. Google Chrome, 

Firefox, Opera, Brave, etc.
2. 	 It can store the URLs you like or need to visit often in a separate collection called Bookmarks.
3. 	 Raman can use the New Incognito window option in the browser then a new browser window 

opens which Raman can use to browse the internet with no history maintained. This means that 
the visited URLs will not be added to history.

4. 	 To search and add multiple destinations in Google Maps, Kirti can follow these steps:
	 i. 	 Search First Destination: Open Google Maps, type the name of the first destination in the search 

bar, and click on it.
	 ii. 	 Add Stops: Click on “Directions” and then select Add Destination to include the second and 

third destinations.
	 iii. 	View Complete Route: Enter the other destinations in order and Google Maps will show the full 

route for all stops.
5. 	 i. 	 Online Free Learning : The internet provides several websites where one can learn about 

almost all the topics through some free courses. Ex: mooc.org , Khan Academy
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	 ii. 	 Searching Locations and Routes: ex: Google maps
	 iii. 	Generative AI Websites : Generative AI models are trained with immense data to create unique 

content of their own.
	 iv. 	 Online Shopping: Many popular websites such as Amazon, Flipkart, Snapdeal, Myntra, etc. 

allow us to buy a variety of items, clothes, accessories, groceries, etc.
	 v. 	 News and Information: All popular newspapers, magazines, and news channels have their 

websites where we can have the latest news and details of events.

Chapter 8 – Scratch: Event driven programming
A. 	 Choose the correct answer.
	 1. d 	 2. a 	 3. c 	 4. b 	 5. a     	 6. c
B.	 Fill in the blanks.
	 1. if    	 2. Operators   	 3. Answer   	 4. Event    	 5. White
C. 	 Answer the following questions.
1. 	 In Scratch, an event is something that occurs due to user action or sprite’s action.
	 Examples of events in Scratch:
	 i. 	 When green flag clicked 	 ii.	 When space key pressed. 
	 iii. 	When this sprite clicked 	 iv.	 When backdrop switches to [backdrop name]
2. 	 Operator Block that helps in comparing or performing arithmetic operations.
3.	 i. 	 Create a variable named A by clicking on the Variables category and selecting Make a Variable.
	 ii. 	 Use the “set [A] to” block from the Variables category.
	 iii. 	Drag the “pick random [1] to [100]” block from the Operators category and place it inside the 

“set [A] to” block.
4. 	 The if-else block in Scratch helps in making decisions based on a condition. It allows the program 

to choose between two actions: one if the condition is true, and another if the condition is false.
	 Suppose you want a sprite to say “Hello!” if the score is greater than 50, or “Try again!” if the score 

is 50 or less.
	 i. 	 Use the if-else block.
	 ii. 	 In the if part, check if the score is greater than 50.
	 iii. 	In the else part, make the sprite say “Try again!” if the score is not greater than 50.
5.	 Wait: Pauses the execution of the script for a specified number of seconds.
	 Forever: Repeats the blocks inside it infinitely.
	 Say: Makes the sprite display a message for a specified amount of time.
	 Answer: stores the user input when the ask block is used. It automatically holds the text entered 

by the user in response to a prompt.
	 Join: Combines two pieces of text into one string.
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Chapter 9 – Animate with Wick Editor
A. 	 Choose the correct answer.
	 1. a 	 2. c 	 3. d 	 4. a 	 5. b     	 6. b    	 7. b    	 8. c
B. 	 Fill in the blanks.
	 1. Layer 	 2. Timeline 	 3. Inspector	 4. Asset Library	 5. Toolbar
C. 	 Answer the following questions.
1. 	 Frame is a static drawing on stage whereas animation is the running series of frames in a sequence.
2. 	 Inspector: This panel shows the properties of the selected objects. These properties can be changed 

as we need.
	 Asset Library: This panel allows us to add our own images and audio files which we can add in 

our animation.
3. 	 Tweening refers to process of object animating from the starting frame to the ending frame.
4. 	 The buildings should be placed in the bottom layer (background layer) and the dog should be 

placed in the top layer (foreground layer). If we reverse this order (put the dog in the bottom layer 
and the buildings in the top layer), the dog would appear behind the buildings and we would not 
be able to see the dog’s movement clearly.

Chapter 10 – Exploring Artificial Intelligence
A. 	 Choose the correct answer.
	 1. a 	 2. b 	 3. a 	 4. c 	 5. b     
B. 	 Fill in the blanks.
	 1. Humans 		  2. Positive, negative, neutral 	 3. Practice   		  4. Machine learning 	
	 5. Learning
C. 	 Answer the following questions.
1. 	 A smart machine is not truly intelligent. It can follow pre-programmed instructions or learn 

patterns from data (like in AI), but it lacks the ability to think, feel, or make decisions on its own.
2. 	 i.	 Text Understanding 	 ii.	 Language Generation 	 iii.	 Sentiment Analysis 
	 iv.	 Text Classification 	 v.	 Image Recognition
3. 	 The field of developing machines which can learn and perform tasks like humans do is called 

artificial intelligence. Common AI applications are face-recognition, driverless cars, fraud detection, 
recommending products.

4. 	 i. 	 Generation of new content: AI applications can create realistic images, videos, presentations, 
audios, etc. based on the description given to them. Such applications are called Generative AI.

	 ii. 	 Visual Search: Allows users to search for visually similar images or objects. Ex- Google Lens
5. 	 Machine learning is the way to train the computers to do various tasks instead of  

programming them.
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CLASS 6
Chapter 1 – MS Word: Tabular Data and Graphics

A. 	 Choose the correct answer. 
	 1. a 	 2. c 	 3.  d	 4.  c	 5. c	   
B. 	 Fill in the blanks. 
	 1. Illustrations	 2. Gradient	 3. Images, Shapes	 4. Cropping		  5. Diagonally
C.  	 Answer the following questions. 
1. 	 i. 	 Select the picture.
	 ii. 	 Click on the Format tab > Size group > Crop option.
	 iii. 	The image is surrounded by eight black crop handles.
	 iv. 	 Grab the handle with the mouse and drag inwards to keep the desired image.
	 v. 	 Press Enter key to finish the cropping.
2. 	 Shape Effects drop-down is used to apply various special effects on the shape such as shadow, 

reflection, bevel, 3D rotation, etc.
3. 	 go to Insert tab > Table drop-down>Use Insert Table...option to display the Insert Table dialog box 

> mention the number of rows=5 and columns=2 and click OK.
4. 	 Renu needs to  Merge two adjacent cells into one cell> first select them then > Layout tab > Merge 

group > Merge Cells option.
5. 	 Icons: Icons are tiny images like clipart.
	 3D Objects: Graphics with height, width, and depth for realistic effects.
	 WordArt: Decorative text styles used to enhance titles or headings.
	 Shapes: Predefined geometric or custom figures added to documents.
	 Images: Pictures or photographs inserted to visually support the content.

Chapter 2 – MS PowerPoint: Multimedia
A. 	 Choose the correct answer. 
	 1. c 	 2. d 	 3.  b	 4.  d	 5. a	   
B. 	 Fill in the blanks. 
	 1. Media	 2. Trimming	 3. One   	 4. Copyright		  5. Audio
C.  	 Answer the following questions. 
1. 	 Audio and video make presentations more interesting and clearer. They help explain ideas better 

and keep the audience engaged.
2. 	 Screen recording is a very interesting and useful feature. This allows to record the video of what 

you do on the computer screen – where you clicked or typed something or opened a window, 
etc. Whatever is seen on the screen is recorded and saved as a video. This video is automatically 
inserted on the current slide.



26

3. 	 i.	 Play: This option in Preview group can be used to play and pause the audio clip.
	 ii.	 Volume: This can be set to low, medium, high or mute.
	 iii.	 Loop until Stopped: Check this box if you need the clip to run non-stop repeatedly.
4. 	 Steps to insert a video:
	 Go to Insert tab > Video drop-down in the Media group > select This Device option > In the Insert 

Video dialog box, locate the desired file.> Click on Insert button.
	 Steps to trim a video
	 click on Trim Video option in Editing group under Playback tab > Slide green pointer to adjust the 

start of the clip > Slide red pointer to adjust the end of the clip > Use Play control to play and check 
the desired video > Click OK.

5. 	 Play Across Slides: Check this box to keep the audio running even when slide is changed to  
other slides.

	 Play full screen: Check this box to run the video in the full screen of the computer monitor.

Chapter 3 – MS PowerPoint: Animation & Transition
A. 	 Choose the correct answer. 
	 1. c 	 2. b 	 3.  b	 4.  c	 5. b	   
B. 	 Fill in the blanks. 
	 1. Entrance		  2. Action Button	 3. Animation Pane   		  4. Fade	 5. Duration
C.  	 Answer the following questions. 
1. 	 Slide transition is an effect that occurs when moving from one slide to the next in a presentation. 

It enhances presentation flow, adds visual appeal, and emphasizes key points.
2. 	 Go to the Animations tab > Animation group > More drop-down arrow > Select the entrance category
3. 	 First, open the Animation Pane then follow these steps:
	 In the Animation Pane, click the drop-down arrow on the right side of the animation and select the
	 Start with Previous option to run this animation along with the animation before it or the Start 

After Previous option to run this animation after the previous animation finishes.
4. 	 Action Buttons: Adding action buttons to navigate slides and perform interactive actions.
5. 	 Start with Previous: Makes the animation begin simultaneously with the previous animation. Start 

after Previous: Makes the animation begin immediately after the previous animation finishes.

Chapter 4 – Excel Fundamentals: Simplifying Data Operations
A. 	 Choose the correct answer. 
	 1. c 	 2. a 	 3.  b	 4.  b	 5. b    	 6. c    	 7. b     	 8. d  
B. 	 State ‘T’ for True and ‘F’ for False. 
	 1. T	 2. F	 3. F   	 4. T	 5. T
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C.  	 Fill in the blanks.
	 1. Home    	 2. Data Analysis    	 3. Highlight     	 4. Categories     	 5. Numbers
D.  	 Answer the following questions.
1. 	 The purpose of sorting data in Excel is to organize it in a specific order for easier analysis  

and presentation.
2. 	 Filtering data helps in data management by focusing on specific information that meets certain 

criteria and requirement, it helps to analyze and manage data.
3. 	 The conditional formatting feature allows us to specify the cell formatting which should be applied 

if cell contains a specific value.
4. 	 First select the column data for which subtotal should applied then go to > Data tab > Outline 

group > Subtotal option.
5. 	 These operations will help us manage and understand our data better.

Chapter 5 – Internet Communication
A. 	 Choose the correct answer. 
	 1. b	 2. d 	 3.  a	 4.  d	 5. d    
B. 	 Fill in the blanks.
	 1. Attachment	 2. Trash	 3. Draft	 4. Stickers, Emojis	 5. Double tick, double blue tick
D.  	 Answer the following questions.
1. 	 o 	 Free, fast and efficient. Most of the features are free to use. Messages deliver almost instantly 

and managed in efficient way.
	 o 	 Easy to use.
	 o 	 Intelligent features like word suggestions, smart reminders to check mail, smart suggestions to 

manage mails.
2. 	 Structure of an email
	 To field: Takes names of the recipient email addresses.
	 Cc field: Carbon copy field takes the email addresses of recipients who are part of the communication.
	 Bcc field: Email addresses of the recipients in Blind Cc field cannot see who other recipients have 

received this message.
3. 	 Received Emails are stored in the Inbox, deleted Emails in the Trash, and sent Emails in the  

Sent folder.
4. 	 Service Mode, Audio/Video Chat, Media Sharing, Chat rooms/groups:
	 Service Mode: Chat feature is available in the form of chat application like WhatsApp or built-in as 

web service with another website or media platform such as Facebook has its own messenger.
	 Audio/Video Chat: Today, owing to affordable internet rates and high speed of transmission, chat 

has taken the form of audio and video chat. People can group chat in live video form for quicker 
and easier communication.
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5. 	 Social media platforms offer significant benefits in terms of connectivity, learning, and marketing, 
but they also present risks related to privacy, mental health, and the spread of misinformation.

Chapter 6 – HTML: An Introduction
A. 	 Choose the correct answer. 
	 1. d	 2. a 	 3.  c	 4.  c	 5. a   
B. 	 State ‘T’ for True and ‘F’ for False..
	 1. F   	 2. T    	 3. F      	 4. T     	 5. F
C.  	 Fill in the blanks.
	 1. Title tag  		  2. BR, P   	 3. Face   	 4. URL    	 5. Start
D. 	 Answer the following questions.
1. 	 HTML provides the basic building blocks to organise the contents of a web page.
	 Element is the name of the basic markup notations in HTML. For example: bold, italics, heading, etc.
	 Attributes are used to set properties of elements.
2. 	 Element: Element is the name of the basic markup notations in HTML. For example: bold, italics, 

heading, etc
	 Tag: Indicates an element, For example: <B> for bold, <I> for italics.
	 Attribute: Sets properties of an element in its starting tag.
3. 	 Container tags: Have both an opening and closing tag and can enclose content.
	 Empty tags: Do not have a closing tag and are used to insert elements or perform actions without 

enclosing content.
4.	 <BR>: Adds a line break.
	 <P>: Defines a paragraph with space before and after it.
	 <PRE>: Displays preformatted text, preserving whitespace and line breaks.
5. 	 The <font> element in HTML was used to define the font, size, and color of the text within it.
	 Ex: <p><font face=”Arial” size=”5” color=”blue”>This is a text with Arial font, size 5, and blue 

color.</font></p>

Chapter 7 – Computer Languages
A. 	 Choose the correct answer. 
	 1. c	 2. d 	 3.  a	 4.  d	 5. d   
B. 	 Fill in the blanks.
	 1. NOT   	 2. Event     	 3. SQL     	 4. Fourth    	 5. Moules
C. 	 Answer the following questions.
1. 	 1st Generation: Machine Language - Direct binary code communication.
	 2nd Generation: Assembly Language - Symbolic representation of machine code.
	 3rd Generation: High-Level Languages - Abstracted from hardware, easy to use.
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	 4th Generation: Fourth-Generation Languages - Focused on specific tasks like database 
management.

	 5th Generation: Fifth-Generation Languages - AI and logic-based programming, declarative.
2. 	 1st Generation: Direct binary code, tied to specific hardware.
	 2nd Generation: Symbolic representation, uses mnemonics for easier programming.
	 3rd Generation: Human-readable syntax, portable across platforms.
	 4th Generation: Task-focused,  minimal coding required.
	 5th Generation: AI and logic-driven, uses declarative problem-solving for complex tasks.
3. 	 Translates the entire program into machine code before execution whereas Interpreter ranslates 

and executes the program line-by-line.
4. 	 comparison operators help with decision-making by comparing values, while arithmetic operators 

perform mathematical operations necessary for calculations.
5. 	 Pseudocode is an informal language that helps the programmers develop algorithms.
	 Begin
   		  Display “Enter the length of the rectangle:”
		  Accept length
		  Display “Enter the width of the rectangle:”
		  Accept width
		  perimeter = 2 * (length + width)
		  Display “The perimeter of the rectangle is:”, perimeter
	 END

Chapter 8 – Scratch Programming
A. 	 Choose the correct answer. 
	 1. c	 2. c 	 3.d	 4.  c	 5. c   
B. 	 Fill in the blanks.
	 1. events   	 2. else    	 3. when I receive     	 4. backdrop    	 5. control
C.	 Match the following blocks with their correct functions.
	 1. d	 2. b	 3. e	 4. a	 5.c 
D. 	 Answer the following questions.
1. 	 The “if” block runs instructions if the condition is true.
	 The “else” block runs instructions when the condition is false.
2. 	 The “repeat” block is used when you know the exact number of repetitions.
	 The “repeat until” block is used when you want to keep repeating until a condition is satisfied.
3. 	 Variables make code more efficient, flexible, and interactive.
	 They store data, track changes, and reduce the need for repeating code.
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	 Variables are key to creating dynamic Scratch projects that respond to user inputs or changing 
conditions.

4. 	 Broadcast blocks allow sprites to send and receive messages, enabling communication  
between them.

	 Clone handling blocks allow for the creation, management, and deletion of clones, making it 
possible to have multiple instances of a sprite that behave independently.

5. 	 It is essential for making your program interactive, efficient, and responsive to user input or other 
external factors.

Chapter 9 – Introduction to Python
A. 	 Choose the correct answer. 
	 1. c	 2. b 	 3.d	 4.  b	 5. b    	 6. a    	 7. d   	 8. d   
B. 	 State ‘T’ for True and ‘F’ for False..
	 1. T   	 2. F    	 3. F     	 4. T   	 5. F
C. 	 Fill in the blanks.
	 1. Data structure    	 2. Images, audio    	 3. Hardware, operating system   
	 4. Editor    			   5. Floor division
D. 	 Answer the following questions:
1. 	 Easy to Learn and Follow, Open-source language,  Huge collection of libraries, Best suited for AI 

and Machine Learning Development.
2. 	 Web Development, Game Development, Data Science and Machine Learning, Education
3. 	 A data structure is a way of organizing, managing, and storing data so that it can be accessed and 

modified efficiently.
4. 	 Python libraries are pre-written collections of code that provide functions and tools to perform 

common tasks. 
	 Benefits of Python libraries:
	 Time Efficiency: Libraries provide pre-built functions and modules, reducing the amount of code 

a developer needs to write. This saves time and speeds up development.
	 Simplified Code: By using libraries, developers can perform complex tasks with fewer lines of 

code.
5. 	 Interactive mode: Interface to run individual commands.
	 Script mode: Interface to allow users to create, modify, save and run scripts.
6. 	 Variables are the unique names given to the values in the commands or scripts. For example, in a 

game program, as user keeps winning, his score is kept updating in a variable.

Chapter 10 – Artificial Intelligence Concepts and Experience
A. 	 Choose the correct answer. 
	 1. b	 2. d 	 3.c	 4.  d	 5. d    
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B. 	 Fill in the blanks.
	 1. Science, Art    	 2. Alexa, Siri    	 3. Negative   	 4. Positive    		  5. Neutral
C. 	 Answer the following questions:
1. 	 Artificial intelligence is the field to develop machines (computers) which should think and act like 

human beings. applications of AI are chatbots, task automation, preventing fraudulent transactions, 
filter spam emails etc.

2. 	 5 applications of AI: Healthcare, Finance, Autonomous Vehicles, Natural Language Processing 
(NLP), Robotics

	 Healthcare: AI is used in healthcare to enhance the diagnosis process, predict diseases, and assist 
in treatment planning.

	 Autonomous Vehicles: AI is a critical component in self-driving cars. It enables vehicles to navigate 
and make decisions without human intervention.

3. 	 Chatbot: An AI-enabled chat app that understands and speaks human languages.
	 Digital assistants understand the commands in popular human languages. Ex, Siri, Alexa etc. 
4. 	 The AI applications that learn from the existing content and generate new content from it are 

called Generative AI applications. Generative AI takes a small description from the user about 
what it is to be created. This is called a prompt. Based on the prompt, it generates new text, images, 
videos and other media.

CLASS 7
Chapter 1 – Netizens on Internet

A. 	 Choose the correct answer. 
	 1. d	 2. b 	 3.  d	 4.  c	 5. c	   
B. 	 Fill in the blanks. 
	 1. Auction, classified ads    	 2. OTP   	 3. Add to cart    	 4. Blog      	  5. Cyberbullying 
C.  	 Answer the following questions. 
1. 	 E-Commerce, also called electronic commerce, refers to the process of selling and purchasing goods 

and services over an E-Commerce website using the internet. Following are the four categories of 
E-commerce: Business to Consumer (B2C), Business to Business (B2B), Consumer to Business 
(C2B), Consumer to Consumer (C2C)

2. 	 Advantages to Consumers:
	 o 	 E-Commerce enables customers to do shopping at any time anywhere.
	 o 	 E-Commerce provides customers with more choices.
	 Technical disadvantages of E-Commerce:
	 o 	 Some security vulnerabilities, such as customer data storage are highly risky. A lack of system 

security might lead to cyber fraud.
	 o 	 Slow internet speed and lack of bandwidth may affect the services.
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3. 	 Social networking sites like Facebook, X (old name, Twitter), Instagram and LinkedIn. These 
platforms help us to connect with friends, family, professionals, and businesses. They encourage 
knowledge-sharing and are all about personal and social interactions. A blog is an online platform 
where we publish our ideas, as well as general and specific topics, regularly.

4. 	 a. 	 Net banking: Bank account holders can use a net banking account to make money transfers, 
check their bank account balances, and more at anytime, anywhere by using a secure internet 
connection.

	 b. 	 Blogging: When bloggers regularly publish articles on their blog page or website, that process 
is called blogging.

	 c. 	 E-Governance: Electronic governance or e-governance is a system in which the government 
uses information and communication technology (ICT) to perform its functions.

	 d. 	 Social networking: it is a platform which help us to connect with friends, family, professionals, 
and businesses. They encourage knowledge-sharing and are all about personal and social 
interactions.

5.	 Bullying that takes place on social media platforms is known as cyberbullying. It makes other 
individuals uncomfortable and harasses them by making unpleasant remarks and in many different 
ways such as social status shaming, body shaming, racial remarks, etc. Cyberbullying primarily 
affects teenagers and children.

Chapter 2 – Mastering Mail Merge: Connecting Words and Data
A. 	 Choose the correct answer. 
	 1. b 	 2. b 	 3. c	 4.  c	 5. a      	 6. c   	 7. d   	 8. a
B.	 Fill in the blanks. 
	 1. Mail merge  	 2. Data   	 3. Mailings      4. data source     5. Finish & Merge 
C.  	 Answer the following questions. 
1. 	 Go to Mailings tab.> Go to Start Mail Merge drop-down.> Click on Step-by-Step Mail Merge
	 Wizard option. This will open up Mail Merge pane.> Select Letters option (default).> Click Next: 

Starting document.> You have the letter opened already, so select Use the current document 
option.> Click Next: Select recipients.> Since you have data source ready, select Use an existing 
list option.> Click Browse... to locate the data source.> In Select Data Source dialog box, locate and 
select the data source.> Click Open button.> In the Select Table dialog box, select the sheet that 
contains the desired data. >Click Ok.> In the Mail Merge Recipients dialog box, click OK button.> In 
Mailings tab, click

	 Insert Merge Field drop-down.> One-by-one, select the fields that you want to insert in main 
document.> Mailings tab > Finish & Merge drop-down > Select Edit Individual Documents option.

2. 	 Companies use mail merge to create copies of the same letter for each customer with each 
customer’s name, address, and other details. This saves a lot of time and effort.

3. 	 It contains recipients’ information in spreadsheet or Word table.
4. 	 To insert merge fields in a mail merge document:
	 o 	 Open your document and go to the Mailings tab.
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	 o 	 Start Mail Merge and connect to a data source.
	 o 	 Place the cursor where you want the field.
	 o 	 Click Insert Merge Field and select a field (e.g., Name, Address).
	 o 	 Repeat for other fields, preview results, and finish the merge.
5. 	 Sending Invitations, Business Letters, Certificates and Awards, Newsletters.

Chapter 3 – MS Excel: Charts
A. 	 Choose the correct answer. 
	 1. b 	 2. b 	 3. b	 4.  c	 5. b      	 6. a   	   
B. 	 State ‘T’ for True and ‘F’ for False. 
	 1. F      	 2. F   	 3. T     	 4. T     
C.  	 Fill in the blanks. 
	 1. Charts     2. Visualise, interpret     3. Legend      4. Y-axis      5. Data Series
D.  	 Answer the following questions. 
1. 	 Changing the Chart Style or Type: You can modify the chart style or switch between different types 

of charts (e.g., column, line, pie) to better represent the data.
	 Modifying Chart Elements: You can customize elements like the title, legend, data labels, axis 

labels, and colors to make the chart more visually appealing and informative.
2. 	 This acts like a key, explaining what each colour or shape in the chart represents. It’s helpful when 

you have multiple data series on the same chart.
3. 	 The X-axis shows the categories or time progression, and the Y-axis shows the values or 

measurements
4. 	 A bar chart is a better choice than a pie chart when comparing values across different categories, 

especially when there are multiple categories or when precise comparisons of values are needed. 
Bar charts are also more effective for displaying data over time.

5. 	 One benefit of using charts to represent data is that they make it easier to visualize trends, patterns, 
and relationships in the data, allowing for quicker and clearer analysis

Chapter 4 – Algorithms, Flowcharts and Pseudocodes
A. 	 Choose the correct answer. 
	 1. b 	 2. d 	 3. d	 4.  c	 5. a	 6. d	 7. b	 8. b
B. 	 Match the following symbols with their purpose or use in a flowchart.
	 Circle	 	 Connect parts of flowcharts across multiple pages.
	 Diamond		  To show decision making and branch out Yes (True) and No (False).
	 Capsule	 	 Shows beginning and ending of a flowchart.
	 Rectangle		  Computation and processing of values.
	 Parallelogram	 Taking input of showing output.
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C.  	 Answer the following questions. 
1.	 Algorithms provide a step-by-step procedure to solve problems, guiding the programming  

process efficiently.
2. 	 A flowchart helps understand an algorithm by visually mapping out its steps, making the logic 

clearer and easier to follow
3. 	 Logic and Precision, Creativity, Attention to Detail, Continuous Learning, Collaboration. 
4. 	 i. 	 Calculate the area of a right-angle triangle.
		  Algorithm:
		  Start
			   Input base and height of the triangle.
			   Calculate the area: Area = (base * height) / 2
		  Print area.
		  End

	 ii. 	 Calculate 10% discount on the total price of an item if 10 or more units are purchased; 
otherwise, 5% discount.

							       Algorithm:
							       Start
							       Input total price and quantity of items.
	 	 	 	 	 	 	 If quantity ≥ 10, 10% discount:
							       Discounted Price = Total Price - (Total Price * 10 / 100)
							       Else, apply a 5% discount:
							       Discounted Price = Total Price - (Total Price * 5 / 100)
							       Print discounted price.
							       End

	 iii. 	 Check if the input username and password match with “user1” and “k1ngd@m”.
		  Algorithm:
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		  Start
			   Input username and password.
			   If username = “user1” and password = “k1ngd@m”:
			   Print “Access granted”
		  Else:
			   Print “Access denied”
		  End

Chapter 5 – Number System: Bits & Bytes
A. 	 Choose the correct answer. 
	 1. d	 2. c 	 3.  c	 4.  c	 5. b    
B. 	 State ‘T’ for True and ‘F’ for False. 
	 1. F   	 2. T    	 3. T     	 4. T       	 5. T  
C.  	 Fill in the blanks. 
	 1. ON, OFF   		 2. Twelve   	 3. Binary to decimal conversion     4. Nibble      5. Base2
D.  	 Answer the following questions. 
1. 	 To convert any decimal number to its equivalent binary number system, follow the steps-
	 o 	 Divide the decimal number by 2.
	 o 	 Record the remainder (it will be either 0 or 1).
	 o 	 Repeat the division with the quotient until the quotient becomes 0.
	 o 	 The binary equivalent is the sequence of remainders read from bottom to top.
2. 	 Number System : It is the way to represent numbers or means by which we count in different ways.
	 There are two types of number systems.
	 o 	 Non-positional Number System
	 o 	 Positional Number System
3. 	 Place value is the fundamental principle in all positional number systems. Each digit in a number 

has a position, and its value is determined by the digit itself, base of the number system and 
position of the base.
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	 Binary Number System (Base-2)
	 Binary uses only two digits: 0 and 1.
	 The place value of each digit in binary is determined by successive powers of 2, starting from 20 at 

the rightmost position.
	 Octal Number System (Base-8)
	 Octal uses eight digits: 0 to 7.
	 The place value of each digit in octal is determined by successive powers of 8, starting from 80 at 

the rightmost position.
4. 	 Nibble is collection of 4 bits whereas byte is a collection of 8 bits.

Chapter 6 – HTML Tables and Hyperlinks
A. 	 Choose the correct answer. 
	 1. c	 2. b 	 3.  a	 4.  a	 5. a    
B. 	 Fill in the blanks. 
	 1. bgcolor   	 2. background   	 3. Width  	 4. cities.html#city1	 5. internal
C.  	 Answer the following questions. 
1. 	 HTML tables display data in a structured form.
2. 	 border=”2”: Sets the border thickness of the table to 2 pixels.
	 bgcolor=”yellow”: Sets the background color of the table to yellow.
	 width=”80%”: Sets the width of the table to 80% of the available space.
	 cellspacing=”10”: Adds a 10-pixel space between the cells of the table.
	 cellpadding=”5”: Adds a 5-pixel space between the content and the cell borders.
3. 	 The colspan and rowspan attributes are used to merge table cells:
	 colspan: Merges a cell across multiple columns.
	 rowspan: Merges a cell across multiple rows.
	 Ex: 
		  <table border=”1”>
    		  <tr>
   		  <th colspan=”2”>Employee Name</th>
    		  <th rowspan=”2”>Position</th>
    		  </tr>
    		  <tr>
    		  <td colspan=”2”>John Doe</td>
    		  </tr>
    		  <tr>
     		  <td>Jane Smith</td>



37

     		  <td>Jane Doe</td>
     		  <td>Manager</td>
   		  </tr>
    		  </table>
4. 	 Hyperlinks help organise website content and provide easy navigation of the website. Hyperlinks 

are of three types – external, internal and multiple links to same file.
5. 	 Internal links stay within the same website, while external links point to different websites.

Chapter 7 – Speech Translation App with MIT App Inventor
A. 	 Choose the correct answer. 
	 1. b		  2. c 		  3.  c		  4.  c		  5. d     	 6. a   
B. 	 Fill in the blanks. 
	 1. Layout  		 2.Property   	 3. Media 		  4. Rucksack   	 5. Math, Text
C.  	 Answer the following questions. 
1. 	 App is a software specifically designed to be installed on the handheld devices.
	 o 	 Apps are easy to download and install on the device.
	 o 	 Apps are mostly free and very light weight (on memory and processor).
	 o 	 Apps generally do not have license restrictions as software have.
2.	 Web apps are responsive versions of their websites.
	 Hybrid apps demonstrate the features of both native and web apps.
3. 	 Designer: For creating the app’s layout and interface.
	 Blocks: For adding functionality and logic to the app.	
4. 	 The Properties panel allows you to configure the components’ attributes to define how the app 

will look and behave.
5.	 i. 	 Button.Click: This block is triggered when a user clicks a button.
	 ii. 	 Set [Component].Text to: This block is used to set the text property of a component, such as a 

Label or Button.
	 iii. 	If-Else: The If-Else block allows you to perform different actions based on certain conditions.
	 iv. 	 Math.Add: This block performs addition of two numbers.
	 v. 	 Notifier.ShowAlert: This block is used to display a message to the user in the form of an  

alert dialog.

Chapter 8 – Python Basics: Decision-making and Loops
A. 	 Choose the correct answer. 
	 1. d	 2. a 	 3.  a	 4.  b	 5. d     	 6. c   
B. 	 Fill in the blanks. 
	 1. input() 	 2. print()   	 3. Condition  		  4. Tab   	 5. break, continue
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C.  	 Answer the following questions. 
1. 	 i. 	 Python’s simple English language-like keywords and syntax makes it easier to learn 

programming.
	 ii. 	 Python is absolutely free! It can be modified freely and distributed freely.
	 iii. 	Python has a huge collection of pre-designed programs called libraries. They can be picked and 

used in our programs to save time and effort.
	 iv. 	 Python has maximum libraries for artificial intelligence and machine learning. Hence, it is most 

suited for developing AI and ML applications.
2. 	 The else keyword in Python is used to define a block of code that runs when the condition in an 

if statement or the loop condition is False. It can be used in conjunction with if, for, and while 
statements.

	 Ex: age = 18
	 if age < 18:
    		  print(“You are not eligible to vote.”)
	 else:
    		  print(“You are eligible to vote.”)
3. 	 A loop is a fundamental programming construct that allows for the repeated execution of a block 

of code as long as a specified condition is met. It is significant because it enables efficient and 
concise handling of repetitive tasks, reducing the need for writing redundant code.

4. 	

5. 	 The break keyword is used to immediately terminate a loop (either a for or while loop) before it 
has completed all its iterations.

Chapter 9 – Retouching Images and Artwork with GIMP
A. 	 Choose the correct answer. 
	 1. d	 2. b 	 3.  c	 4.  d	 5. c   

for Loop
Used when the number of iterations is 
known or a sequence needs to be iterated.

Iterates over a sequence (like a list, range, 
or string).

Implicitly checks the end of the sequence.

Iterating over fixed data structures or 
ranges.

for i in range(5):

while Loop
Used when the number of iterations is 
unknown and depends on a condition.

Repeats as long as the condition remains True.

Explicitly checks the condition before each 
iteration.

Executing code until a dynamic condition is 
met.

while i < 5:
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B. 	 Fill in the blanks. 
	 1. Text 	 2. Color Picker   	 3. Tolerance  	 4. Flattened  	 5. Locked
C.  	 Answer the following questions. 
1. 	 The multiple selection tools in GIMP provide users with different approaches to suit various types 

of images and tasks, allowing for greater control, precision, and speed in the editing process.
2. 	 Crop Tool (Shift+C): This is used to remove the unwanted part of the image. Cropping is done from 

the outer edges of the image towards inner region.
	 Rotate (Shift+R): Helps in rotating the image or selection.
	 Scale (Shift+S): Changes the size of the selection.
3. 	 It allows us to keep various parts of our art work on separate layers. This way it is easier to work 

with one part of art work without affecting other parts.
4. 	 You can right click on any layer in the Layers panel and apply the following:
	 Flatten Image: GIMP layers can be merged together to create the final single image. This process is 

called flattening. Flattened image, once saved, cannot be broken back into layers.
	 Merge Down: This merges the current layer to the layer right below it.
	 Duplicate Layer: Makes a copy of the layer.
	 Delete Layer: Deletes a layer.
5. 	 Filters apply special effects on the art work. GIMP provides hundreds of filters arranged in various 

categories under Filters menu.
D. 	 Match the GIMP Tool with its correct use.
	 1. f	 2. d 	 3. b	 4. e	 5. a	 6. c

Chapter 10 – Artificial Intelligence Concepts
A. 	 Choose the correct answer. 
	 1. b	 2. a 	 3.  b	 4.  c	 5. a   	 6. d  
B. 	 Fill in the blanks. 
	 1. Reasoning, Learning 	 2. Understand, Interpret, Generate  	 3. Augmented  
	 4. Input, Hidden, Output 	 5. Trained, Tested
D.  	 Answer the following questions. 
1. 	 Artificial Intelligence (AI) is the field to develop machines that perform tasks like humans do.
2. 	 Healthcare, Education, Finance, E-commerce, Transportation, Entertainment, Manufacturing, 

Agriculture. 
3. 	 In Machine learning, AI models are trained with the help of existing data.
	 Deep learning is machine learning based on artificial neural network that works like human brain.
4. 	 In an artificial neural network, there are 3 layers of neurons namely input layer, output layer and 

one or more hidden layers in the middle. All the computing is done in the hidden layers of the 
input data that comes through input layer and the output goes through the output layer.
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CLASS 8
Chapter 1 – Cyberthreats and Cybersecurity

A. 	 Choose the correct answer. 
	 1. d 	 2. b 	 3.  a	 4.  b	 5. b    	 6. c	   
B. 	 Fill in the blanks. 
	 1. Black    		  2. Cyber detective 		  3. Card cloning     	 4. Software piracy       
	 5. Worms   		  6. HTTPS  
C.  	 Answer the following questions. 
1. 	 a. 	 Cybercrime: Unauthorised access with the intention of misuse of someone’s personal data is 

called cybercrime.
	 b. 	 Cyberthreat: a threat is a procedure that causes critical damage to computer systems.
	 c. 	 Cybersecurity: Cyber security refers to the measures to prevent any type of online attack on 

any secret or personal information.
	 d. 	 Cyberbullying: Cyberbullying is an act of harassing someone online in different ways.
2. 	 4 types of cybercrime: i. Black Hat Hacking 2. Cyberattack and Cyber Terrorism 3. Credit Card 

Fraud 4. Software Piracy
	 i.	 Software Piracy: Software piracy is a sort of cybercrime that involves the unauthorised copying, 

distribution, and usage of software programs for commercial or personal profit.
	 Ii.	 Credit Card Fraud: This attack occurs when hackers gain access to a retailer’s computer systems 

to steal credit cards or banking information from customers.
3. 	 Common Security Measures:
	 i. 	 Keep updating the operating system of your smartphone or computer regularly.
	 ii. 	 Install licensed anti-virus software from a reputable company on the computer, mobile device, 

or tablet.
	 iii. 	When we use emails or log in to a bank’s website to make a transaction, we should use a  

strong password.
	 iv. 	 Open the email attachment carefully, and do not open any email attachments from an  

unknown sender.
4. 	 We should never indulge in cyberbullying because it can cause severe emotional distress, harm 

mental health, damage reputations, and even lead to legal consequences. Respecting others online 
fosters a safer and more positive digital environment for everyone.

5. 	 Trojan: a trojan appears to be a useful program (game, utility, movie clip, etc.) but in fact it causes 
harm. In comparison to other threats.

	 Worms: It is a comparatively mild threat. However, it replicates and has the potential to spread 
from one machine to another within a network system.

	 Spyware: Spyware’s job is to monitor all your activities on the computer as well as your data and 
transfer it to the external party.
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Chapter 2 – Excel Formulas and Functions
A. 	 Choose the correct answer. 
	 1. a 	 2. b 	 3. b	 4. a	 5. b    	   
B. 	 Match the functions with its use.
	 1>h 	 2>d 	 3>a 	 4>b 	 5>c 	 6>g 	 7>f  	 8>e 
C.  	 Answer the following questions. 
1.	 SUM = Total of values. AVERAGE = Mean of values.
2.	 COUNT: Counts only numeric cells. COUNTA: Counts all non-empty cells (including text,  

numbers, etc.).
3. 	 CONCAT function in Excel can be used to combine text from multiple cells into one. For example: 

If the cell AI contains the first name and cell B1 contains the last name, and if we want to combine 
them into full name in the cell C1. We can do so with the concat() formula : =concat(A1, “ ”,B1)

4.	 MIN(): Returns smallest of given values in a range or a set of values.
	 Syntax: =MIN(cell range) ; =MIN(value1, value2,...)	
	 Example: =MIN(D2:D11) ; =MIN(D2, D5, D7, D11)
	 MAX(): Returns highest of given values in a range or a set of values.
	 Syntax: =MAX(cell range) ; =MAX(value1, value2,...)	
	 Example: =MAX(D2:D11) ; =MAX(D2, D5, D7, D11)
5.	 To add the values in cells B1 to B5, you would use the SUM function:
	 Formula: =SUM(B1:B5)

Chapter 3 – Introduction to RDBMS
A. 	 Choose the correct answer. 
	 1. a	 2. c 	 3.  c	 4.  b	 5. b    	   
B. 	 State ‘T’ for True and ‘F’ for False. 
	 1. F   	 2. T    	 3. F     	 4. F       	 5. F  
C. 	 Fill in the blanks. 
	 1. Database   	 2. DBMS   	 3. Clean and Tidy     	 4. Primary       5. Foreign  
D.  	 Answer the following questions. 
1. 	 i. 	 Integrity Enforcer:  A DBMS enforces data integrity by defining rules and constraints, preventing 

errors and inconsistencies from creeping into your data.
	 ii. 	 Security Guardian:  A DBMS allows you to set user access controls, ensuring only authorised 

individuals can view, modify, or delete sensitive information.
2. 	 A column whose values uniquely identify each row in a table is called a primary key.
	 Significance: It helps keep the data organised and easy to retrieve.
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3. 	 A DBMS protects sensitive data through authentication (user verification), authorization (role-
based access), and encryption (secure data storage and transfer). It also offers audit logs, data 
masking, and backup/recovery to ensure data security and integrity.

4. 	 Foreign Key: A foreign key is like a link or connection between two tables on the basis of common 
fields. 

	 Let’s use a school database as an example:
	 1. Students Table
		  o This table has information about students.
		  o Columns: StudentID, Name, Grade
	
	 2. Subjects Table
		  o This table has information about the subjects 	

	    students are taking.
		  o Columns: SubjectID, SubjectName, StudentID  

	  (foreign key)
	 In this example, the StudentID in the Subjects Table is the foreign key.
5. 	 Databases are used in various fields to manage information:
	 o 	 Education: Student records, course information, grades.
	 o 	 Business: Customer data, inventory management, product information.
	 o 	 Healthcare: Patient records, medical history, appointment management.
	 o 	 Finance: Bank accounts, transactions, financial data.
	 o 	 Science: Research data, experiment results, scientific literature.
6. 	 Advantages of using DBMS
	 o 	 Organisation Powerhouse: A DBMS organises your data meticulously, eliminating redundancy 

(repeated information) and ensuring everything has its designated place.
	 o 	 Efficiency : A DBMS acts like a lightning-fast search engine for your data. 
	 o 	 Security Guardian:A DBMS allows you to set user access controls, ensuring only authorised 

individuals can view, modify, or delete sensitive information.
	 o 	 Integrity Enforcer: A DBMS enforces data integrity by defining rules and constraints, preventing 

errors and inconsistencies from creeping into your data.
	 o 	 Sharing: A DBMS facilitates easy data sharing and concurrent access, ensuring everyone works 

with the most up-to-date information.

Chapter 4 – Working with MS Access
A. 	 Choose the correct answer. 
	 1. d	 2. a 	 3.  d	 4.  b	 5. b    	 6. d   	 7. b	   

StudentID	 Name	 Grade
	 1	 Alice	 8
	 2	 Bob	 7

		SubjectID	 SubName	 StudentID
		 101	 Maths	 1
		 102	 Science	 2
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B. 	 State ‘T’ for True and ‘F’ for False. 
	 1. F   	 2. T    	 3. T     	 4. F       	 5. T  
D.  	 Answer the following questions. 
1.	 To create a database in MS Access:
	 Open MS Access and click on File > New.
	 Select Blank Database.
	 Enter a name for your database in the “File Name” box.
	 Choose a location to save the database and click Create.
2. 	 AutoNumber automatically generates unique sequential numbers, while Text stores alphanumeric 

data that can be manually edited.
3. 	 In MS Access, tables are related to ensure data integrity and avoid duplication by linking related 

data across multiple tables.
	 Example:
	 A Customers table may store customer information (CustomerID, Name), and an Orders table 

stores order details (OrderID, CustomerID, OrderDate). By relating the CustomerID in both tables, 
you can retrieve all orders made by a specific customer without duplicating customer data.

4. 	 Table Design View: Used to define the structure of the table, including specifying field names, data 
types, and primary keys. It allows you to modify the table’s design.

	 Table Datasheet View: Displays the actual data in the table, similar to a spreadsheet. You can view, 
edit, and enter records in this view.

5. 	 Enforcing referential integrity in MS Access ensures that related data in different tables stays 
accurate. It prevents issues like having an order without a matching customer and ensures that 
changes in one table are properly reflected in related tables.

Chapter 5 – HTML Lists and Images
A. 	 Choose the correct answer. 
	 1. a	 2. b 	 3.  c	 4. d	 5. b	   
B. 	 Either one of the two or both the statements in the following sets are false. Mark the True 

ones.  
	 1. i 	 2. ii 	 3. i	 4. i	 5. ii  
C.  	 Answer the following questions. 
1. 	 Ordered lists are suitable when we need to display a sequence of tasks or steps to do something. 

For example, steps to switch off a computer or list of students with serial number. Unordered lists 
are used to show the list of items, objects, or events such as grocery list, summary points, bullet 
list of important facts.

2. 	 In HTML, an image can be aligned with respect to the text in the following ways:
	 o 	 Inline – This is by default; image stays with the flow of the text. 
	 o 	 Left – Align the image left to the text. 
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4. 	 In an ordered list, the attribute “type” is used to specify the style of numbering such as  
alphabet, decimal, or roman numeral, etc. The “start” attribute determines the starting value of 
the numbered 

1. 	 Apple

	 •	 Vitamins

		  o	Vitamin C

		  o	Vitamin K

	 •	 Minerals

		  o	Potassium

		  o	Magnesium

	 •	 Other Nutrients

		  o	Dietary Fiber

		  o	Antioxidants (e.g., Quercetin)

2. 	 Banana

	 •	 Vitamins

		  o	Vitamin B6

		  o	Vitamin C

	 •	 Minerals

		  o	Potassium

		  o	Magnesium

	 •	 Other Nutrients

		  o	Dietary Fiber

		  o	Natural Sugars (e.g., Glucose, Fructose)

List starts with letter “c”:
<OL type= “a” start= “2”>
<LI>Item 1</LI>
<LI>Item 2</LI>
<LI>Item 3</LI>

</OL	List starts with uppercase 
roman numeral “VII”:

<OL type= “I” start= “7”>
<LI>Item 1</LI>
<LI>Item 2</LI>
<LI>Item 3</LI>

</OL Default – starts with 
number “3”:

<OL start= “3”>
<LI>Item 1</LI>
<LI>Item 2</LI>
<LI>Item 3</LI>
</OL

	 o	 Right – Align the image right to the text. 
	 o	 Center – Center align the image on the web page. 
	 o	 Middle – Align the image vertically in the middle with respect to the text. 
	 o	 Top – Align the text next to the top side of the image. 
	 o	 Bottom - Align the text next to the bottom side of the image.
3. 	 When a list is created inside another list then it is called Nested list. We can create a list inside 

another list to show the hierarchies or levels. Any type of list can be nested in another type. 
For example:

Output:
c. Item 1
d. Item 2
e. Item 3

Output:
VII. Item 1
VIII. Item 2
IX. Item 3

Output:
3. Item 1
4. Item 2
5. Item 3
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Chapter 6 – HTML Forms
A. 	 Choose the correct answer. 
	 1. b	 2. b	 3.  a	 4. a	 5. a	 6. d	   
B. 	 Fill in the blanks.  
	 1. button, reset, submit	 2. 1	 3. Multiple,0	 4. <option>	 5. <select>  
C.  	 Answer the following questions. 
1. 	 HTML forms are used to collect data from the website visitors for various purposes such as 

registration details, feedbacks & surveys, application forms, enquiry forms, order forms, etc.
2. 	 To create a submit button with caption “Save” we will use input element with type and value 

attribute as shown below:
	 <input type= “submit” value= “Save”>
3. 	 Drop-down list opens when user clicks on it while scroll list has a pre-defined size defined by 

“size” attribute. 
	 Example – drop-down list:
	 <select>
	 <option value= “1”>Red</option> <option value= “2”>Green</option>
	 <option value= “3”>Blue</option> <option value= “4”>Black</option>
	 </select>
	 Example – scroll list:
	 <select name= “colours” size= “3”>
	 <option value= “1”>Red</option> <option value= “2”>Green</option>
	 <option value= “3”>Blue</option> <option value= “4”>Black</option>
	 </select>
4. 	 Ronit will mention the attribute “multiple” in <select> tag and for first five <option> tags, he will 

mention the attribute “selected”.
	 E.g. <select name= skills” “multiple”><option value= “1” “selected”>Writing</option>…….  

</select> 

Chapter 7 – Python Lists
A. 	 Choose the correct answer. 
	 1. d	 2. b	 3.  a	 4. a	 5. a  
B. 	 Write the name of the correct Python list method against the following actions:
	 1. append	 2. remove	 3. insert	 4. extend	 5. sort  
C.  	 Answer the following questions. 
1. 	 Python lists are flexible data structures used to store different types of values. They are useful in 

storing multiple values and refer to them by one name. For example, marks of students, scores of 
players, names of items and cities, list of prices, etc.
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2. 	 Five characteristics of Python are:
	 i. 	 Python lists are useful to store multiple values and access them easily. 
	 ii. 	 Values stored in Python lists can be accessed by zero-based index.
	 iii. 	Python lists are mutable (their contents can be changed).
	 iv. 	 A Python list can store different types of data. 
	 v. 	 Python lists can store other lists within them called nested lists.
3. 	 insert(): 
		  List1=[‘apple’, ‘1 kg’, ‘120’] 
		  List1.insert(1, ‘fruit’) 
		  Result: [‘fruit’,‘apple’, ‘1 kg’, ‘120’]
	 remove():
		  List1=[‘apple’, ‘1 kg’, ‘120’] 
		  List1.remove(120) 
		  Result: [‘apple’, ‘1 kg’]
4. 	 Let us assume that we have this list: marks = [50, 80, 20]
	 a. 	 Sort a list in descending order:		  marks.sort(reverse=True)	 Result: [80, 50, 20]
	 b. 	 Calculate the number of items in a list:	 len(marks)			   Result: 3 
	 c. 	 Reverse a list: 				    marks.reverse()		  Result: [20, 50, 80]

Chapter 8 – Video Editing with Shotcut
A. 	 Choose the correct answer. 
	 1. d	 2. c	 3.  d	 4. a	 5. b  
B. 	 State ‘T’ for True and ‘F’ for False.
	 1. F	 2. T	 3. F	 4. F	 5. T
C. 	 Fill in the blanks.  
	 1. Append	 2. Timeline	 3. Ripple	 4. Markers	 5. MLT, Media
D.  	 Answer the following questions. 
1. 	 Playlist allows us to add all the media files which should be the part of our project in Shotcut. 

Timeline is used to add the media clips from the Playlist and edit them as required.
2. 	 Modifying the video clips in various ways such as splitting, changing clips sequences, applying 

special effects (filters), adding multipl tracks, exporting final video, etc. is part of video editing.
3.	 Filters are special audio/video effects that can be applied on the track.
4. 	 We can apply Gain/Volume filter on the media clip from the Filters panel and set its volume as we 

need.
5. 	 To add tracks on the Timeline, open the Timeline menu > Track operations > Add Audio Track 

option and Add Video Track option. 



47

Chapter 9 - Introduction to Photoshop
A. 	 Choose the correct answer. 
	 1. b	 2. a	 3.  a	 4. d	 5. a  
B. 	 Fill in the blanks.  
	 1. Alt		 2. Gradient	 3. Background	 4. Tolerance		  5. Alt + Click
C.  	 Answer the following questions. 
1. 	 Some times we need to merge multiple selections or subtract some part from the existing selection 

or select only the common area of two overlapping selections. For this purpose, we need different 
selection modes.

2. 	 Rectangular marquee (for rectangular selection), Crop tool (to crop image), Red eye (remove 
red eye effect), Sharpen tool (makes pixels more distinct), and Clone Stamp tool (copy and paste 
pixels).

3. 	 We can select Spot Healing tool and apply it on the spotted regions of the image.
4. 	 Pen tool and Freeform Pen tool are used to create complex shapes such as curves and curls.
5. 	 Mix of two or more colours is called Gradient.
E. 	 Compare the following tools with their correct function.
	 Students are advised to solve it themselves.

Chapter 10 - Character Animation using Animate
A. 	 Choose the correct answer. 
	 1. b	 2. c	 3.  c	 4. d	 5. b	   
B. 	 Fill in the blanks.  
	 1. Frame	 2. Keyframe	 3. Morphing	 4. Bone	 5. Layers
C. 	 Answer the following questions. 
1.	 Each static drawing in the animation is represented by a frame. Keyframe represents a significant 

change in the animation.
2.	  Timeline is like the working desk for the animator. It allows apply animation effects in the frames, 

add layers, and manage entire animation.
3. 	 Tween is the process of showing change in animation from one frame to another frame. All the 

animations between the starting and ending frames are generated automatically. Motion tween 
is used to move the object from one point to another while shape tween is used to change the 
appearance of the object.

4. 	 A symbol is a reusable drawing, button or animation clip. It is stored in the animation library. We 
can create one or more instances of a symbol to use in the animation. For example, wheel of a car, 
buttons, trees, flying bird, etc.

5. 	 Onion skin feature is helpful in frame-by-frame animation when we need to see the drawings on 
previous frames and frames ahead to adjust the correct position of an object in the current frame.
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A. 	 Choose the correct answer. 
	 1. c	 2. b	 3.  a	 4. a	 5. a	 6. c	   
B. 	 Fill in the blanks.  
	 1. Alexa, Siri		 2. Predictions	 3. Deep	 4. Generative	 5. Fake
C. 	 Answer the following questions. 
1. 	 Please remove the terms “deep learning” and “machine learning” from the question. Artificial 

intelligence is the field to develop machines that can learn and do tasks like humans do. 
2. 	 Six applications of artificial intelligence are Sentiment Analysis, Chatbots and Virtual Assistants, 

Autonomous Vehicles, Medical Image Analysis, Generative AI (creates new content by learning 
from existing content), and Surveillance & Security.

3. 	 Generative AI is a branch of artificial intelligence focused on creating new content or data that 
resembles what humans produce. Based on existing data and interactions with the users, generative 
AI can generate new, unique data.

4. 	 Some major ethical issues with GenAI are it is used to deepfake videos of real people. This 
may seriously affect that person’s social life. It can be used to create fake news leading to mass 
disturbance. It may ne a threat to personal data and employment of many people in different 
industries specially, creative arts. 

Max duration Frame rate Play button

Keyframe
Tween

Frame

Onion skin 
button

Layer with tween
Frame numbers

Onion skin marker 
of previous frames

D. 	 Identify the Key Elements.

Chapter 11- AI Concepts & Generative AI


